Garrett ace 150 problem

Only topics related to the Garrett ace 150 metal detector here.
Post Reply
User avatar
DetectorScot
Posts: 12
Joined: Sun Jun 04, 2017 12:16 am
Been thanked: 2 times

Garrett ace 150 problem

Post by DetectorScot » Fri Aug 11, 2017 8:27 pm

Hey, I've had my 150 for a few months now and recently have had a problem with it. The depth detection seems to be completely gone. I've tried tightening the connection - new batteries - resetting it -

Nothing seems to works. Could anyone help me?

Lowland
Posts: 40
Joined: Wed Mar 29, 2017 9:18 am
Location: scottish middle march
Has thanked: 9 times
Been thanked: 28 times
Contact:

Re: Garrett ace 150 problem

Post by Lowland » Sat Aug 12, 2017 7:39 am

Hi detectorscot,
Might be a stupid question
But
Is this happening with a bench test as well as in the field?....i imagine soil conditions can effect the garretts depth effectiveness.
Did with my 250.
I apologise if that was a stupid question,
At least your machine will still be under warranty if needs be.
Cheers

User avatar
DetectorScot
Posts: 12
Joined: Sun Jun 04, 2017 12:16 am
Been thanked: 2 times

Re: Garrett ace 150 problem

Post by DetectorScot » Sat Aug 12, 2017 12:31 pm

I've been back to places it has worked before and it still doesn't work. I think its just got a fault. I've contacted Garrett, so hopefully they can get it fixed for me.

Post Reply

Return to “Garrett ACE 150 Forum”

Who is online

Users browsing this forum: No registered users and 1 guest